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End-to-End Troubleshooting Guide: Issues Viewing Mixer Streams

You can check the Mixer Service Health Dashboard  to see if there are currently any known service issues.

Introduction: Viewer Issues vs. Broadcaster Issues

For a conceptual description of all that can go wrong between the broadcaster and the viewer of a stream on Mixer, please see the article on How streaming traffic is delivered. This end-to-end troubleshooting guide for issues viewing Mixer streams is logically arranged to focus on the viewer experiencing the issue, but the troubleshooting steps often involve coordination between the broadcaster, the viewer, and Mixer (and sometimes even your ISP) to resolve. For help resolving additional broadcaster issues please see End-to-End TSG: Issues Broadcasting Mixer Streams.

Viewer Issues: Problems watching a Mixer stream

Buffering:

Broadcaster Causes:

  1. The broadcaster's encoder settings are set too high and their hardware can't handle it. The broadcaster may need to adjust their stream settings.
  2. The broadcaster's game or other software is capping out their CPU and not leaving enough resources for the encoder (xsplit/obs). A common symptom is buffering when action gets intense in an FPS. The broadcaster should try setting their encoder software's CPU Process Priority higher than the thing that's CPU-Hogging in Task Manager in Windows.
Networking Causes:
  1. There is a network problem between the broadcaster and the Mixer ingest server (all viewers of this stream suffer). The broadcaster may need to or change ingest servers.
  2. There is a network problem between the viewers and the Mixer distribution server (fewer viewers of this stream suffer). The viewer should find the distribution server by right clicking in the stream and then run an MTR or Traceroute to it to check for speed issues.
  3. The broadcaster's ISP, the viewer's ISP, or an ISP in the middle may be throttling Mixer traffic. The broadcaster or viewer can run an MTR or Traceroute to see where the traffic is slow. 

Viewer Causes:

  1. The viewer's settings are too high and their Internet bandwidth can't handle it. The viewer should adjust their settings to avoid buffering or view the stream at a lower bandwidth.
  2. The viewer's browser is having issues. The viewer should try clearing their browser cache, refreshing the page with CTRL + F5, updating their browser to the newest version, and testing from a different browser (note which Browsers work).
  3. The Mixer 1.0 interface is available for troubleshooting, but the Mixer 2.0 interface should work faster in normal use and can be set from: https://mixer.com Settings - Account - Choose Site Version

Mixer Causes:

  1. There is a server side issue at Mixer.
    You can check Mixer service health from: https://status.mixer.com/
    Please let us know if a stream is broken.

Black Screens:

Symptoms:

  1. Stream never starts and the screen stays black.
  2. Stream starts, but then goes black.
  3. Stream starts, but then goes black and shows "NAN:NAN".
  4. Stream shows the blue buffering icon, and then the screen goes black.
  5. Stream starts, but then switches from the HTML player (with the blue FTL icon) to Flash, and then the screen goes black.
  6. Stream gives "WebRTC not supported" errors.

(Please specify the exact symptom if you report an issue with the Mixer black screens.)

Possible Causes:

  1. Flash plugin issues. The viewer should update the Flash plugin for their browser.
  2. FTL issues. The viewer can tell if the stream uses FTL by looking for the circular blue FTL icon to the right of the volume control. Then they should try setting their video player to default to flash in their player preferences (or try forcing Flash, on the bottom of the Channel tab on your Dashboard).
    • To watch Mixer FTL streams in "Low Latency" mode, you will need to use a browser that supports the "h264 video codec", such as the latest versions of Chrome, Firefox, or Edge (starting with the Windows 1o Creator Update). A WebRCT Test can also be used to help troubleshoot Low Latency issues.
  3. Browser issues. The viewer should try clearing their browser cache, refresting the page with CTRL + F5, updating their browser to the newest version, and testing from a different browser.
  4. Mixer issues. The viewer can open a Developer's Console and see if there are any errors when the stream fails.
  5. Local computer issues. The viewer should try watching from a different computer and document the hardware and software differences if it works from one PC but not another.
  6. Network/Internet connection speed issues. The viewer should try from a different Internet connection, and send us the results of an MTR or Traceroute.
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